Задать вопрос
31 мая, 11:42

Электрическая цепь составлена из Электрическая цепь составлена из нескольких сопротивлений. Определите сопротивление между узлами А и Б.

Нужно написать программу в Паскале.

Между А и Б сопротивление

R1, R (общее R2, R3), R4 соединены последовательно, а R2 и R3 параллельно.

Т. е. общее сопротивление равно ...

R=R1 + (R2*R3) / (R2+R3) + R4

на основании этой формулы нужна программа.

+1
Ответы (1)
  1. 31 мая, 14:34
    0
    Var

    r, r1, r2, r3, r4 : real;

    begin

    write ('R1 = ') ; readln (r1) ;

    write ('R2 = ') ; readln (r2) ;

    write ('R3 = ') ; readln (r3) ;

    write ('R4 = ') ; readln (r4) ;

    r : = r1 + (r2 * r3) / (r2 + r3) + r4;

    writeln ('R = ', r) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Электрическая цепь составлена из Электрическая цепь составлена из нескольких сопротивлений. Определите сопротивление между узлами А и Б. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, которая вычисляет сопротивление электрической цепи, состоящей из двух сопротивлений. Сопротивления могут быть соединены последовательно или параллельно.
Ответы (1)
2. Написать программу вычисления состоящей из двух сопротивлений. Сопротивления могут быть соединены последовательно или параллельно. Вычисления сопротивления электрической цепи.
Ответы (1)
Система из двух последовательных сопротивлений R1 и R2 соединена параллельно с сопротивлением R3. К цепи приложено напряжение V. Найти силу тока в каждом из сопротивлений. (В паскале)
Ответы (1)
Помогите сделать программу в Паскале В котором 1) Программа выдает сообщение "Вы маль или дево" 2) Пользователь в переменную ST1 задает значение маль или дево 3) Программа выдает сооб "Ты пошла бы играть в куклы" 4) Вводить ответ через переменную
Ответы (1)
Разработать программу, реализующую следующий функционал: 1.1. Программа запрашивает у пользователя число от 1 до 10 (n). 1.2. Программа проверяет введенное число на правильность: больше либо равно 1 и меньше либо равно 10. 1.3.
Ответы (1)