Задать вопрос
18 декабря, 16:14

Написать программу, которая вычисляет сопротивление электрической цепи, состоящей из двух сопротивлений. Сопротивления могут быть соединены последовательно или параллельно.

+5
Ответы (1)
  1. 18 декабря, 18:54
    0
    Program soprotiv; {Название программы}

    var r1, r2:real; {Задаем переменные}

    c:byte;

    begin {Начало программы}

    write ('Введите 1 сопротивление ... ') ; {Вывод сообщения о вводе данных}

    readln (r1) ; {Ввод данных с клавиатуры}

    write ('Введите 2 сопротивление ... ') ; {Вывод сообщения о вводе данных}

    readln (r2) ; {Ввод данных с клавиатуры}

    write ('Если соединение параллельное, то нажмите клавишу 1, если соединение последовательное - нажмите 0 ... ') ; {Вывод сообщения о вводе данных}

    readln (c) ; {Ввод данных с клавиатуры}

    if c=1 {условие}

    then writeln ('Сопротивление электрической цепи, соединенной параллельно=', (r1*r2) / (r1+r2)) {Вывод значения, при параллельном соединении}

    else writeln ('Сопротивление электрической цепи, соединенной последовательно=', (r1+r2)) ; {Вывод значения, при последовательном соединении}

    end. {Конец программы}
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая вычисляет сопротивление электрической цепи, состоящей из двух сопротивлений. Сопротивления могут быть соединены ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
2. Написать программу вычисления состоящей из двух сопротивлений. Сопротивления могут быть соединены последовательно или параллельно. Вычисления сопротивления электрической цепи.
Ответы (1)
Написать программу в Pascal вычисления сопротивления электрической цепи, состоящей из 2-х параллельно соединенных сопротивлений. (Величина первого сопротивления 15 Ом второго сопротивления 20 Ом)
Ответы (2)
Написать функцию, вычисляющую сопротивление электрической цепи, состоящей из двух сопротивлений. Параметрами функции должны быть величины этих сопротивлений и тип соединения (0 - последовательное, 1 - параллельное).
Ответы (1)
Составить алгоритм в виде блок-схемы и программу для вычисления сопротивления электрической цепи, состоящей из двух последовательно соединенных сопротивлений. Получить результаты при: a. R1=11 Ом; R2=35 Ом b. R1=2,5 Ом; R2=3,5 Ом
Ответы (1)
Разработать пользовательскую функцию, которая вычисляет сопротивление цепи, состоящей из двух резисторов. Параметрами функции являются величины сопротивлений и тип соединения (последовательное или параллельное).
Ответы (1)