Задать вопрос
1 июня, 11:15

2. Написать

программу

вычисления

состоящей из двух сопротивлений. Сопротивления могут быть соединены

последовательно или параллельно.

Вычисления сопротивления электрической цепи.

Введите исходные данные:

Величина первого сопротивления (Ом) - > 15

Величина второго сопротивления (Ом) - > 27.3

Тип соединения (1 - последовательное, 2 - параллельное) - > 2

Сопротивление цепи: 9.68 Ом.

на Pascal.

+1
Ответы (1)
  1. 1 июня, 12:23
    0
    Var r, r1, r2:real; t:integer;

    Begin

    Readln (r1, r2) ;

    Readln (t) ;

    If t=1 then r:=r1+r2

    Else if t=2 then r: = (r1*r2) / (r1+r2) ;

    Write (r:3:2) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «2. Написать программу вычисления состоящей из двух сопротивлений. Сопротивления могут быть соединены последовательно или параллельно. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу в Pascal вычисления сопротивления электрической цепи, состоящей из 2-х параллельно соединенных сопротивлений. (Величина первого сопротивления 15 Ом второго сопротивления 20 Ом)
Ответы (2)
Написать функцию, вычисляющую сопротивление электрической цепи, состоящей из двух сопротивлений. Параметрами функции должны быть величины этих сопротивлений и тип соединения (0 - последовательное, 1 - параллельное).
Ответы (1)
Разработать пользовательскую функцию, которая вычисляет сопротивление цепи, состоящей из двух резисторов. Параметрами функции являются величины сопротивлений и тип соединения (последовательное или параллельное).
Ответы (1)
Написать программу, которая вычисляет сопротивление электрической цепи, состоящей из двух сопротивлений. Сопротивления могут быть соединены последовательно или параллельно.
Ответы (1)
Напишите программы для следующих задач, организуя экран пользователя по предложенному варианту. Задача 1:Написать программу вычисления площади поверхности параллелепипеда. S=2 * (A*B+B*C+C*A) Введите данные А=9, В=7.
Ответы (1)