Задать вопрос
4 апреля, 22:31

Помогите сделать программу в Паскале

В котором

1) Программа выдает сообщение "Вы маль или дево"

2) Пользователь в переменную ST1 задает значение маль или дево 3) Программа выдает сооб "Ты пошла бы играть в куклы"

4) Вводить ответ через переменную ST2 да или нет

5) Если ST2=да, а ST1=девочка то выдается сооб "Кого пригласишь с собой"

6) Пользователем через переменную ST3 вводит имя

7) Программа выводит сооб "Вы и [Указывается имя] пошли играть!"

8) В противном случае (пункт 5) программа выдает сооб "А вы ничего не перепутали "

9) Программа выдает сооб "Game Over"

+4
Ответы (1)
  1. 5 апреля, 00:46
    0
    Var ST1, ST2, ST3:string;

    Begin

    writeln ('Вы мальчик или девочка?') ;

    readln (ST1) ;

    writeln ('Ты пошла бы играть в куклы?') ;

    readln (ST2) ;

    if (ST2 = 'да') and (ST1 = 'девочка') then begin

    writeln ('Кого пригласишь с собой?') ;

    readln (ST3) ;

    writeln ('Вы и ', ST3,' пошли играть!') ;

    end

    else

    writeln ('А вы ничего не перепутали?') ;

    writeln ('Game Over') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите сделать программу в Паскале В котором 1) Программа выдает сообщение "Вы маль или дево" 2) Пользователь в переменную ST1 задает ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами.
Ответы (1)
1) Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения элементов массива с противоположным знаком.
Ответы (1)
3. Напишите и выполните программу на компьютере a. Программа вводит одно число, и вычисляет его квадрат, вычитая из него удвоенное значение введенного числа. b. Программа вводит два числа, выводит сумму квадратов этих чисел минус их произведение. c.
Ответы (1)
Паскаль ABC Пользователь вводит с клавиатуры два числа. Если сумма чисел больше, либо равна 100, то программа выводит "Разряд выше десятков", если сумма меньше 100, но больше либо равна 10, то программа выводит "Разряд выше единиц", если сумма чисел
Ответы (1)