Задать вопрос
24 февраля, 18:57

Разработать программу, реализующую следующий функционал:

1.1. Программа запрашивает у пользователя число от 1 до 10 (n).

1.2. Программа проверяет введенное число на правильность: больше либо равно 1 и меньше либо равно 10.

1.3. Если введенное число попадает в диапазон 1:10, программа вычисляет произведение последовательности чисел от 1 до n, то есть n! ("n факториал"). Результат вычисления выдается в виде сообщения пользователю.

1.4. Если введенное число не попадает в диапазон от 1 до 10 включительно, то программа выдает сообщение об ошибке и завершает свое выполнение.

+2
Ответы (1)
  1. 24 февраля, 19:37
    0
    Program z_1;

    var i, n, fact:longint;

    begin

    writeln ('введите число от 1 до 10) ;

    read (n) ;

    fact:=1;

    if (n>=1) and (n<=10) then

    for i:=1 ti n do

    fact:=fact*i

    else

    write ('число не входить в диапозон от 1 до 10') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Разработать программу, реализующую следующий функционал: 1.1. Программа запрашивает у пользователя число от 1 до 10 (n). 1.2. Программа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите сделать программу в Паскале В котором 1) Программа выдает сообщение "Вы маль или дево" 2) Пользователь в переменную ST1 задает значение маль или дево 3) Программа выдает сооб "Ты пошла бы играть в куклы" 4) Вводить ответ через переменную
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Составьте программу которая выводит на экран пример на умножение двух целых чисел, запрашивает ответ пользователя. проверяет его и выводит соответсвующиеся сообщения : "Правильно!" либо "Вы ошиблись". а также правильный результат
Ответы (1)
С помощью repeat S = (x / (факториал) 1) + (х^2 / (факториал) 2) + (х^3 / (факториал) 3) + ... + (х^n / (факториал) n) + 0,0001
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)