Задать вопрос
7 февраля, 01:04

дан целочисленный массив из 40 элементов, все элементы которого-целые числа в интервале от - 500 до 500. Опишите на русском или на одном из языков программирования алгоритм, который находит среднее арифметическое всех положительных элементов массива, которые кратны первому элементу (делятся нацело на первый элемент)

первый массива отличен от нуля!

+3
Ответы (1)
  1. 7 февраля, 04:45
    0
    var

    sum, n, i:integer;

    m: array [1 ... 40] of integer;

    begin

    randomize;

    writeln ('Введите 1-ый элемент массива: ') ;

    read (m[1]) ;

    writeln ('Массив: ') ;

    write (m[1]:6) ;

    for i:=2 to 40 do

    begin

    m[i]:=random (1001) - 500;

    write (m[i]:6) ;

    end;

    for i:=1 to 40 do

    if (m[i] > 0) and (m[i] mod m[1] = 0) then

    begin

    sum:=sum+m[i];

    inc (n) ;

    end;

    writeln;

    writeln ('Среднее арифметическое = ', sum/n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дан целочисленный массив из 40 элементов, все элементы которого-целые числа в интервале от - 500 до 500. Опишите на русском или на одном из ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите написать программу в паскале Дан целочисленный массив. Он заполняется при запуске программы: сначала запросить число элементов (n от 1 до 40), затем - элементы - целые числа в интервале от - 500 до 500. a.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Дан вещественный массив из 40 элементов. Элементы массива могут принимать произвольные значения. Опишите на русском языке или на одном из языков программирования алгоритм, который находит и выводит минимальный положительный элемент массива или
Ответы (1)
Дан массив из 30-ти элементов. Каждый элемент может принимать целочисл енные значения от - 100 до 100. Напишите программу, которая позволит подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива.
Ответы (1)