Задать вопрос
11 октября, 02:35

Помогите написать программу в паскале

Дан целочисленный массив. Он заполняется при запуске программы: сначала запросить число элементов (n от 1 до 40), затем - элементы - целые числа в интервале от - 500 до 500.

a. количество чисел, оканчивающихся на 3;

b. найти среднее арифметическое всех положительных элементов массива, которые кратны первому элементу (делятся нацело на первый элемент). Гарантируется, что первый элемент массива положительный.

c. наибольший отрицательный элемент, который делится на 3.

+2
Ответы (1)
  1. 11 октября, 04:40
    0
    Var

    a:array[1 ... 40] of integer;

    i, n, k3, k, s, a3:integer;

    begin

    Write ('n=') ; Read (n) ;

    for i:=1 to n do Read (a[i]) ;

    k3:=0; {a}

    s:=0; k:=0; {b}

    a3:=-1000; {c}

    for i:=1 to n do begin

    if a[i] mod 10=3 then Inc (k) ; {a}

    if (a[i]>0) and (a[i] mod a[1]=0) then begin {b}

    s:=s+a[i]; Inc (k)

    end;

    if (a[i]a3) and (a[i] mod 3=0) then a3:=a[i]; {c}

    end;

    Writeln ('Кол-во чисел. оканчивающихся на 3: ', k3) ; {a}

    Writeln ('Среднее арифметическое по условию: ', s/k:0:3) ; {b}

    if a31000 then Writeln ('Наибольший отрицательный, кратный 3: ', a3) {c}

    else Writeln ('Нет отрицательных элементов, кратных 3')

    end.

    Для решения конкретного пункта выбирать только операторы, помеченные этим пунктом, Например, {a} для а)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в паскале Дан целочисленный массив. Он заполняется при запуске программы: сначала запросить число элементов (n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите написать программу! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов.
Ответы (1)
дан целочисленный массив из 40 элементов, все элементы которого-целые числа в интервале от - 500 до 500.
Ответы (1)
Дан массив из 30-ти элементов. Каждый элемент может принимать целочисл енные значения от - 100 до 100. Напишите программу, которая позволит подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива.
Ответы (1)