Задать вопрос
15 ноября, 02:39

Помогите написать программу!

Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и вводятся с клавиатуры. Найти и вывести:

1. Сумму квадратов отрицательных элементов. Гарантируется, что в исходном массиве есть хотя бы один отрицательный элемент.

2. Произведение элементов массива, имеющих четное значение и стоящих на четных местах. Гарантируется, что в исходном массиве есть хотя бы один такой элемент.

3. Количество элементов массива, превосходящих по модулю 100. Гарантируется, что в исходном массиве есть хотя бы один такой элемент.

+4
Ответы (1)
  1. 15 ноября, 03:35
    0
    Const maxn=15;

    var a: array[1 ... maxn] of integer;

    skv, prod, gr, i: integer;

    begin

    writeln ('введите ', maxn,' чисел') ;

    skv:=0; prod:=1;

    gr:=0;

    for i:=1 to maxn do

    begin

    write (i,': ') ; readln (a[i]) ;

    if a[i]<0 then skv:=skv+a[i]*a[i];

    if (a[i] mod 2 = 0) and (i mod 2 = 0) then

    prod:=prod*a[i];

    if abs (a[i]) >100 then gr:=gr+1;

    end;

    writeln ('сумма квадратов отрицательных: ', skv) ;

    writeln ('произведение четных на четных местах: ', prod) ;

    writeln ('больше 100 по модулю: ', gr) ;

    end.

    введите 15 чисел

    1: 151

    2: - 231

    3: 104

    4: 19

    5: 36

    6: - 112

    7: 5

    8: 8

    9: 11

    10: 13

    11: 45

    12: 5

    13: 6

    14: 17

    15: 19

    сумма квадратов отрицательных: 65905

    произведение четных на четных местах: - 896

    больше 100 по модулю: 4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Дан целочисленный массив из 70 элементов. Элементы массива могут принимать целые значения от 0 до 100. Составить программу, позволяющую найти и вывести элементы массива, которые не кратны 9 и находятся в диапазоне[30,70].
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)