Задать вопрос
6 февраля, 01:30

Дан целочисленный массив из 70 элементов. Элементы массива могут принимать целые значения от 0 до 100. Составить программу, позволяющую найти и вывести элементы массива, которые не кратны 9 и находятся в диапазоне[30,70]. Гарантируется, что в исходном массиве есть хотя бы один такой элемент.

+2
Ответы (1)
  1. 6 февраля, 04:45
    0
    Const

    auto = true;

    n = 70;

    var

    a: array[1 ... n] of integer;

    i: integer;

    begin

    for i : = 1 to n do

    begin

    if auto then

    a[i] : = random (100)

    else readln (a[i]) ;

    if (a[i] = 30) and (a[i] mod 9 > 0) then

    writeln (a[i]) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный массив из 70 элементов. Элементы массива могут принимать целые значения от 0 до 100. Составить программу, позволяющую ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Дан целочисленный массив из 10 элементов. Элементы массива могут принимать целые значения от 0 до 1000.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)