Задать вопрос
20 января, 02:19

Дан целочисленный массив из 10 элементов. Элементы массива могут принимать целые значения от 0 до 1000.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти и вывести номер первого элемента массива, который делится на 3.

Гарантируется, что в исходном массиве есть хотя бы один такой элемент.

Программу я написал, но выводит все значения, а мне нужно первое.

+5
Ответы (1)
  1. 20 января, 02:45
    0
    1)

    program gt;

    var a, q, i:integer;

    begin

    q:=0;

    for i:=1 to 10 do

    begin

    read (A) ;

    if (a mod 3=0) then begin

    q:=q+1;

    if (q=1) then writeln (a) ;

    end;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный массив из 10 элементов. Элементы массива могут принимать целые значения от 0 до 1000. Опишите на русском языке или на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Дан вещественный массив из 40 элементов. Элементы массива могут принимать произвольные значения. Опишите на русском языке или на одном из языков программирования алгоритм, который находит и выводит минимальный положительный элемент массива или
Ответы (1)
Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от - 1000 до 1000 включительно. Опишите алгоритм, позволяющий найти и вывести минимальное значение среди отрицательных элементов массива, оканчивающихся на 3.
Ответы (1)
Дан целочисленный массив из 70 элементов. Элементы массива могут принимать целые значения от 0 до 100. Составить программу, позволяющую найти и вывести элементы массива, которые не кратны 9 и находятся в диапазоне[30,70].
Ответы (1)