Задать вопрос
10 октября, 06:36

Составить программу в pascal для нахождения корней квадратного уравнения ax^2+bx+c=0

+1
Ответы (1)
  1. 10 октября, 08:57
    0
    Uses crt;

    var

    d, a, b, c, x1, x2: real;

    begin

    writeln ('Введите a, b, c') ;

    readln (a, b, c) ;

    d : = b * b - 4 * a * c;

    if d > 0 then

    begin

    x1 : = (-b + sqrt (d)) / (2 * a) ;

    x2 : = (-b - sqrt (d)) / (2 * a) ;

    writeln ('x1 = ', x1:2:2) ;

    writeln ('x2 = ', x2:2:2) ;

    end

    else if d = 0 then

    begin

    x1 : = - b / (2 * a) ;

    writeln ('x = ', x1:2:2) ;

    end

    else

    writeln ('Нет действительных корней') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в pascal для нахождения корней квадратного уравнения ax^2+bx+c=0 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) даны 3 числа a, b, c, являющиеся коэффициентами квадратного уравнения. Составить алгоритм и программу для нахождения корней этого квадратного уравнения.
Ответы (1)
1. Составить программу для нахождения площади трапеции. 2. Составить программу для нахождения квадрата суммы двух чисел (по формулам сокращённого умножения). 3.
Ответы (1)
Free Pascal 1. Составить программу для вычисления площади прямоугольника по его длинам сторон a и b. 2. Даны два целых числа x и y. Составить программу для нахождения большего из них. 3.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)