Задать вопрос
24 декабря, 14:24

Free Pascal

1. Составить

программу для вычисления площади прямоугольника по его длинам сторон a и b.

2. Даны

два целых числа x и y. Составить программу

для нахождения большего из них.

3. Составить

программу для вывода на экран натуральных чисел от 1 до 10.

4. Составить

программу для решения задачи: Сколько пирожков испечёт хозяйка за неделю, если

в первый день она испекла 4 пирожка, а в каждый последующий день - в два раза

больше, чем в предыдущий?

5. (*) С

клавиатуры вводятся последовательно N натуральных чисел. Найти большее из них.

+4
Ответы (1)
  1. 24 декабря, 15:23
    0
    1) var a, b, s: real;

    begin

    read (a, b) ;

    s:=a*b;

    writeln (s) ;

    end.

    2) var x, y, max: integer;

    begin

    read (x, y) ;

    if x>y then max:=x else max:=y;

    writeln (max) ;

    end.

    3) var i:integer;

    begin

    for i:=1 to 10 do

    writeln (i) ;

    end.

    4) var i, n:integer;

    begin

    n:=4;

    for i:=1 to 7 do begin

    n:=2*n;

    writeln (n) ;

    end.

    5) var a, n, max:integer;

    begin

    max:=-MaxInt;

    read (n) ;

    for i:=1 to n do begin

    read (a) ;

    if a>max then max:=a;

    end;

    writeln (max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Free Pascal 1. Составить программу для вычисления площади прямоугольника по его длинам сторон a и b. 2. Даны два целых числа x и y. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Дан двухмерный массив m*n случайных целых чисел, которые должны генерироваться в диапазоне [-5, 7], где 1 ≤ т ≤ 9, 1 ≤ n ≤ 10.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Cоставить алгоритм и программу для: 1) Заполнения лвумерного массива (6x4) произвольными значениями и вывода его на экран! 2) Подсчета произведения элементов по строкам и вывода на экран номеров строк и соответствующих произведений элементов!
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)