Задать вопрос
1 марта, 01:10

Cоставить алгоритм и программу для:

1) Заполнения лвумерного массива (6x4) произвольными значениями и вывода его на экран!

2) Подсчета произведения элементов по строкам и вывода на экран номеров строк и соответствующих произведений элементов!

3) Нахождения строки с максимальным произведением элементов и вывода на экран ее номера (номеров) и произведения элементов!

4) Выделения 1-го столбца в отдельный массив и сортировки его по возврастанию методом прямого выбора

+2
Ответы (1)
  1. 1 марта, 05:10
    0
    Const

    m = 6;

    n = 4;

    var

    a: array[1 ... m, 1 ... n] of integer;

    b: array[1 ... m] of integer;

    i, j, p, pmax, imax: integer;

    flag: boolean;

    begin

    {1}

    Randomize;

    writeln ('Исходный массив') ;

    for i : = 1 to m do

    begin

    for j : = 1 to n do

    begin

    a[i, j] : = Random (81) - 40;

    write (a[i, j]:4)

    end;

    writeln

    end;

    {2}

    writeln ('Произведения построчно') ;

    for i : = 1 to m do

    begin

    p : = 1;

    for j : = 1 to n do p : = p * a[i, j];

    writeln (i, ': ', p:9)

    end;

    {3}

    pmax : = - MaxInt;

    writeln ('Максимальное построчное произведение') ;

    for i : = 1 to m do

    begin

    p : = 1;

    for j : = 1 to n do p : = p * a[i, j];

    if pmax < p then

    begin

    pmax : = p;

    imax : = i;

    end

    end;

    writeln (imax, ': ', pmax:9) ;

    {4}

    for i : = 1 to m do b[i] : = a[i, 1];

    for i : = 2 to m do

    begin

    p : = b[i];

    j : = i - 1;

    flag : = False;

    while (j > 0) and (not flag) do

    if p < b[j] then

    begin

    b[j + 1] : = b[j];

    j : = j - 1

    end

    else flag : = True;

    b[j + 1] : = p

    end;

    writeln ('Отсортированный первый столбец') ;

    for i : = 1 to m do writeln (b[i]:3)

    end.

    Тестовое решение:

    Исходный массив

    -27 4 3 14

    15 40 - 39 - 27

    40 - 40 - 40 - 24

    -38 7 18 1

    17 27 29 - 9

    10 - 32 38 0

    Произведения построчно

    1: - 4536

    2: 631800

    3: - 1536000

    4: - 4788

    5: - 119799

    6: 0

    Максимальное построчное произведение

    2: 631800

    Отсортированный первый столбец

    -38

    -27

    10

    15

    17

    40
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Cоставить алгоритм и программу для: 1) Заполнения лвумерного массива (6x4) произвольными значениями и вывода его на экран! 2) Подсчета ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Напишите программу, работающую с одним массивом из 10 элементов целочисленного типа. Программа просит пользователя заполнить массив целыми значениями, затем упорядочивает этот массив по возрастанию, используя сортировку методом простого выбора.
Ответы (1)