Задать вопрос
4 мая, 09:08

Дан двухмерный массив m*n случайных целых чисел, которые должны генерироваться в диапазоне [-5, 7], где 1 ≤ т ≤ 9, 1 ≤ n ≤ 10. Составить программу:

a) вывода на экран элементов исходного массива;

b) вывода на экран элемента, расположенного в правом верхнем углу массива;

c) вывода на экран элемента, расположенного в левом нижнем углу массива;

d) вывода на экран любого элемента второй строки массива;

e) вывода на экран любого элемента третьего столбца массива;

f) вывода на экран любого элемента массива.

+5
Ответы (1)
  1. 4 мая, 10:53
    0
    Const m=9; n=10;

    var

    a:array[1 ... m, 1 ... n] of integer;

    i, j, m1, n1:integer;

    begin

    Randomize;

    writeln ('Исходный массив:') ;

    for i:=1 to m do

    begin

    for j:=1 to n do

    begin

    a[i, j]:=random (13) - 5;

    write (a[i, j]:4) ;

    end;

    writeln;

    end;

    writeln ('Элемент, расположенный в правом верхнем углу массива: ', a[1, n]) ;

    writeln ('Элемент, расположенный в левом нижнем углу массива: ', a[m, 1]) ;

    writeln ('Какой элемент второй строки нужно вывести?') ;

    readln (n1) ;

    writeln ('Элемент, расположенный во второй строке в ', n1,' столбце: ', a[2, n1]) ;

    writeln ('Какой элемент третьего столбца нужно вывести?') ;

    readln (m1) ;

    writeln ('Элемент, расположенный в третьем столбце в (о) ', m1,' строке: ', a[m1,3]) ;

    writeln ('Какой элемент массива нужно вывести?') ;

    readln (m1, n1) ;

    writeln ('Элемент, расположенный в (о) ', m1,' строке в (о) ', n1,' столбце: ', a[m1, n1]) ;

    end.

    Пример:

    Исходный массив:

    7 - 5 7 7 3 3 4 6 - 5 1

    7 - 3 - 1 - 5 - 1 - 1 2 4 - 2 6

    0 3 4 - 2 - 3 - 1 - 2 7 3 - 2

    7 3 - 2 6 - 2 4 - 1 1 0 3

    2 4 - 1 6 - 2 2 5 4 4 - 1

    -1 - 4 5 2 5 - 1 - 5 5 - 5 0

    4 2 - 4 2 - 3 1 - 1 5 3 4

    -2 5 - 4 - 1 5 5 3 3 - 2 1

    5 2 - 3 3 5 4 3 3 4 5

    Элемент, расположенный в правом верхнем углу массива: 1

    Элемент, расположенный в левом нижнем углу массива: 5

    Какой элемент второй строки нужно вывести?

    Элемент, расположенный во второй строке в 4 столбце: - 5

    Какой элемент третьего столбца нужно вывести?

    Элемент, расположенный в третьем столбце в (о) 5 строке: - 1

    Какой элемент массива нужно вывести?

    Элемент, расположенный в (о) 6 строке в (о) 2 столбце: - 4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан двухмерный массив m*n случайных целых чисел, которые должны генерироваться в диапазоне [-5, 7], где 1 ≤ т ≤ 9, 1 ≤ n ≤ 10. Составить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)