Задать вопрос
2 сентября, 06:18

даны два двумерных массива А и B вывести на экран тот из них у которого след меньше (след - сумма элементов главной диагонали)

+4
Ответы (1)
  1. 2 сентября, 06:46
    0
    var a:array[1 ... 10,1 ... 10]of integer;

    b:array[1 ... 10,1 ... 10]of integer;

    i, j, s1, s2:integer;

    begin

    for i:=1 to 10 do for j:=1 to 10 do begin a[i, j]:=random (9) + 1; b[i, j]:=random (9) + 1; end;

    for i:=1 to 10 do begin for j:=1 to 10 do write (a[i, j],' ') ; if j=10 then writeln; end;

    writeln;

    for i:=1 to 10 do begin for j:=1 to 10 do write (b[i, j],' ') ; if j=10 then writeln; end;

    for i:=1 to 10 do

    for j:=1 to 10 do

    if i=j then begin

    s1:=s1+a[i, j];

    s2:=s2+b[i, j];

    end;

    writeln;

    if s1>s2 then for i:=1 to 10 do begin for j:=1 to 10 do write (a[i, j],' ') ; if j=10 then writeln; end else

    for i:=1 to 10 do begin for j:=1 to 10 do write (b[i, j],' ') ; if j=10 then writeln; end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «даны два двумерных массива А и B вывести на экран тот из них у которого след меньше (след - сумма элементов главной диагонали) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)