Задать вопрос
14 августа, 01:25

Составьте программу вычисления количества трёхзначных чисел, у которых цифры упорядочены строго по возрастанию

+3
Ответы (2)
  1. 14 августа, 02:24
    0
    Program Pr;

    var a:array[100 ... 999] of integer;

    q, w, v, c, i, d:integer;

    Begin

    n:=-1;

    c:=1;

    For i:=1 to 899 do begin

    a[i]:=99+c;

    c:=c+1;

    q:=a[i] mod 10;

    a[i]:=a[i] div 10;

    w:=a[i] mod 10;

    a[i]:=a[i] div 10;

    if (q>w) and (q>a[i]) and (w>a[i]) then v:=v+1;

    end;

    writeln ('Всего этих числел=', v) ;

    end.
  2. 14 августа, 02:49
    0
    var

    i, n: integer;

    i1, i2, i3: 1 ... 9; / / Цифры трехзначного числа

    begin

    for i: = 100 to 999 do {Перебираем все трехзначные числа и вычисляем цифры числа}

    begin

    i1: = i div 100;

    i2: = (i mod 100) div 10;

    i3: = i mod 10;

    if (i3 > i2) and (i2 > i1) then inc (n) ; {Если 3 цифра больше 2-й и 2-я больше 1-ой, то увеличиваем счетчик на 1}

    end;

    writeln ('Количество трехзначных чисел, у которых цифры упорядочены строго по возрастанию равно: ', n) ;

    end.

    Если все правильно, отметь решение как лучшее)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу вычисления количества трёхзначных чисел, у которых цифры упорядочены строго по возрастанию ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Найти двухзначные числа, которые делятся на сумму своих цифр 2. Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
Сост. програму вычислить кол-во 3-х значных чисел у которых цифры упорядочены строго по возрастанию
Ответы (1)
Задание 1. составьте программу вычисления количества двузначных чисел, которые кратны 2 и 3. задание 2. составьте программу, выводящую на экран все двузначные числа, у которых первая цифра в два раза больше второй. задание 3.
Ответы (1)
Задача для паскаля. Во входном файле имеется массив из 10 целых чисел. Первые 9 элементов упорядочены. В выходной файл вставить 10-й элемент так, чтобы все элементы массива были упорядочены.
Ответы (1)