Задать вопрос
19 февраля, 16:31

1. Найти двухзначные числа, которые делятся на сумму своих цифр

2. Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.

+4
Ответы (1)
  1. 19 февраля, 18:46
    0
    Var

    i, m, sum:Integer;

    Begin

    for i:=10 to 99 do

    begin

    m:=i mod 10;

    n:=i div 10;

    sum:=m+n;

    if (i mod sum = 0) then Writeln (i) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Найти двухзначные числа, которые делятся на сумму своих цифр 2. Составьте программу вывода количества трёхзначных чисел, у которых цифры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу вычисления количества трёхзначных чисел, у которых цифры упорядочены строго по возрастанию
Ответы (2)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Задание 1. составьте программу вычисления количества двузначных чисел, которые кратны 2 и 3. задание 2. составьте программу, выводящую на экран все двузначные числа, у которых первая цифра в два раза больше второй. задание 3.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)