Задать вопрос
5 ноября, 17:27

Сост. програму вычислить кол-во 3-х значных чисел у которых цифры упорядочены строго по возрастанию

+2
Ответы (1)
  1. 5 ноября, 19:35
    0
    var k, p, v, t, i: integer;

    begin

    i:=100;

    k:=0;

    while i 1000 do begin

    p:=i div 100;

    v: = (i div 10) mod 10;

    t:=i mod 10;

    if (t > v) and (p < v) then

    inc (k) ;

    inc (i) ;

    end;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сост. програму вычислить кол-во 3-х значных чисел у которых цифры упорядочены строго по возрастанию ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу вычисления количества трёхзначных чисел, у которых цифры упорядочены строго по возрастанию
Ответы (2)
Задача для паскаля. Во входном файле имеется массив из 10 целых чисел. Первые 9 элементов упорядочены. В выходной файл вставить 10-й элемент так, чтобы все элементы массива были упорядочены.
Ответы (1)
Задается массив из n натуральных чисел. Найти сумму чисел в которых цифры упорядочены по возрастанию. Язык - паскаль. Задачу сделать надо через функцию
Ответы (1)
поставьте знаки арифметических операций в каждой схеме. А) скорость? время=путь б) путь? время=скорость в) масса 1 батона? количество батонов=общ. масса г) кол. батонов? кол. буханок=общ. кол. д) кол. конфет в 1 коробке? кол. коробок = общ. кол.
Ответы (1)
1. Найти двухзначные числа, которые делятся на сумму своих цифр 2. Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.
Ответы (1)