Задать вопрос
3 января, 06:42

Найти все совершенные числа до 100000. Совершенное число - это такое число, которое равно сумме всех своих делителей, кроме себя самого. Например, число 6 является совершенным, т. к. кроме себя самого делится на числа 1, 2 и 3, которые в сумме дают 6.

+2
Ответы (1)
  1. 3 января, 09:08
    0
    Var i, j, s, n:integer;

    begin

    readln (n) ;

    for i : = 1 to n-1 do

    begin

    s:=0;

    for j : = 1 to (i div 2) do

    if i mod j=0 then s:=s+j;

    if s=i then write (i,' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти все совершенные числа до 100000. Совершенное число - это такое число, которое равно сумме всех своих делителей, кроме себя самого. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На языке паскаль абс написать программу (Не глушилку, а нормальную программу) (желательно с помощью Циклов и If-ов) Натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая само число.
Ответы (1)
Натуральное число M называется совершенным, если оно равно сумме всех своих делителей, включая единицу, но исключая себя, является ли число м совершенным? Напиши программу в паскале циклов while или repeat
Ответы (1)
Напишите программу, которая вводит число N и определяет является ли число N совершенным. Совершенные числа - это те числа, которые равны сумме своих делителей, не включая само число, но включаю единицу
Ответы (1)
Вывести все совершенные числа в промежутке от 1 до 100. Совершенное число это натуральное число равное сумме своих собственных делителей (отличных от самого числа)
Ответы (1)
Дано натуральное число N. Определить, является ли оно совершенным (совершенное число равно сумме всех своих делителей, не превосходящих само число)
Ответы (1)