Задать вопрос
23 февраля, 21:17

На языке паскаль абс написать программу (Не глушилку, а нормальную программу) (желательно с помощью Циклов и If-ов)

Натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая само число. Например, совершенным является число 6 (6=1+2+3).

Необходимо найти все совершенные числа, меньшие заданного числа N.

Формат входных данных

Вводится одно целое число N (1≤N≤100000).

Формат выходных данных

Требуется вывести все совершенные числа, меньшие заданного числа N.

Числа следует выводить в порядке возрастания, разделяя пробелами.

Примеры

входные данные выходные данные

7 6

+5
Ответы (1)
  1. 23 февраля, 22:03
    0
    Ну Хьюстон почти все уже сделал. Я чуток подправил

    var i, j, s, n:integer;

    begin

    readln (n) ;

    for i : = 1 to n-1 do

    begin

    s:=0;

    for j : = 1 to (i div 2) do

    if i mod j=0 then s:=s+j;

    if s=i then write (i,' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На языке паскаль абс написать программу (Не глушилку, а нормальную программу) (желательно с помощью Циклов и If-ов) Натуральное число ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Натуральное число M называется совершенным, если оно равно сумме всех своих делителей, включая единицу, но исключая себя, является ли число м совершенным? Напиши программу в паскале циклов while или repeat
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
задается целое число N. нужно вывести количество четных делителей числа N. Формат входных данных Единственная строка входного файла содержит единственное целое число N (1
Ответы (1)