Задать вопрос
27 октября, 10:09

Найти среднее арифметическое элементов отличных от минимального

Pascal ABC

+4
Ответы (1)
  1. 27 октября, 13:33
    0
    Const n=15;

    var i, k, mn, indm, sm: integer;

    a: array[1 ... n] of integer;

    sar: real;

    begin

    randomize;

    writeln ('исходный массив:') ;

    mn:=n; sm:=0;

    k:=1;

    for i:=1 to n do

    begin

    a[i]:=random (-n, n) ;

    sm:=sm+a[i];

    write (a[i],' ') ;

    if a[i]=mn then k:=k+1;

    if a[i]
    begin

    mn:=a[i];

    indm:=i;

    k:=1;

    end;

    end;

    writeln;

    writeln ('минимальный элемент: ', mn,' индекс: ', indm) ;

    sm:=sm-a[indm]*k;

    writeln ('сумма элементов без минимального: ', sm) ;

    sar:=sm / (n-k) ;

    writeln ('среднее арифметическое: ', sar:7:3) ;

    end.

    исходный массив:

    -1 6 - 12 - 14 14 - 14 10 - 9 - 2 - 6 9 - 1 - 13 13 - 2

    минимальный элемент: - 14 индекс: 4

    сумма элементов без минимального: 6

    среднее арифметическое: 0.462
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти среднее арифметическое элементов отличных от минимального Pascal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Помогите составить программу в Paskal! 1) Вычислите значение минимального элемента массива 2) Вычислите сумму минисального и максимального элементов 3) Выведите номер минимального элемента 4) Выведите номера максимальных элементов и их количество
Ответы (1)
1. Имеется целочисленный массив, состоящий из 15 элементов: a) Найти сумму a[1] и a[7] элементов; b) Найти разность a[9] и a[3] элементов; c) Найти среднее арифметическое всех элементов массива; d) Найти произведение всех элементов массива.
Ответы (2)
Написание разветвляющихся программ на языке Pascal. Задание №1:Если а>b и b>c тогда а = max+3. Задание №2:Вывести на экран среднее арифметическое максимального и минимального из 3 чисел.
Ответы (1)