Задать вопрос
3 октября, 20:00

Помогите составить программу в Paskal!

1) Вычислите значение минимального элемента массива

2) Вычислите сумму минисального и максимального элементов

3) Выведите номер минимального элемента

4) Выведите номера максимальных элементов и их количество

+1
Ответы (1)
  1. 3 октября, 22:08
    0
    Номера минимума и максимума не получается сделать паскаль выделывается чо то

    var a: array[1 ... 5] of integer; i, min, max, summa, nmin, nmax:integer; begin

    for i: = 1 to 5 do readln (a[i]) ;

    min:=a[1]; for i: = 2 to 5 dobeginif a[i]
    end;

    max:=a[1]; for i: = 2 to 5 dobeginif a[i]>a[1] then max:=a[i]; end; summa:=min+max;

    writeln ('min=', min) ; writeln ('min+max=', summa) ; writeln ('nomer min=', nmin) ; writeln ('nomer mmax=', nmax) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите составить программу в Paskal! 1) Вычислите значение минимального элемента массива 2) Вычислите сумму минисального и максимального ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Что определяет для массива X[1 ... n] следующий алгоритм R: = n; For k: = 1 to n do If X[k]
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)