Задать вопрос
7 мая, 00:17

1. Имеется целочисленный массив, состоящий из 15 элементов: a) Найти сумму a[1] и a[7] элементов; b) Найти разность a[9] и a[3] элементов; c) Найти среднее арифметическое всех элементов массива; d) Найти произведение всех элементов массива.

+1
Ответы (2)
  1. 7 мая, 01:41
    0
    const n = 15;

    var

    a: array[1 ... n] of integer;

    i, x: integer;

    begin

    for i : = 1 to n do begin

    a[i] : = random (50) ;

    write (a[i], ' ') ;

    x : = x + a[i];

    end;

    writeln;

    writeln ('a[1] + a[7] = ', a[1] + a[7]) ;

    writeln ('a[9] - a[3] = ', a[9] - a[3]) ;

    writeln ('Среднее арифметическое: ', (x / n) : 0:2) ;

    end.
  2. 7 мая, 03:36
    0
    var

    a: array[1 ... 15] of integer;

    i, n: integer; x:real; m:int64;

    begin

    for i : = 1 to 15 do

    readln (a[i]) ; m:=1;

    for i:=1 to 15 do begin

    x:=x+a[i]; m:=m*a[i]; end;

    writeln ('a[1]+a[7]:=', a[1]+a[7]) ;

    writeln ('a[9]-a[3]:=', a[9]-a[3]) ;

    writeln ('srednee ar.:=', x/15) ;

    writeln ('proizvedenie:=', m) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Имеется целочисленный массив, состоящий из 15 элементов: a) Найти сумму a[1] и a[7] элементов; b) Найти разность a[9] и a[3] элементов; ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)