Задать вопрос
8 февраля, 04:30

Натуральное число M называется совершенным, если оно равно сумме всех своих делителей, включая единицу, но исключая себя, является ли число м совершенным? Напиши программу в паскале циклов while или repeat

+3
Ответы (1)
  1. 8 февраля, 07:30
    0
    Var

    M, S, d:longint;

    Begin

    Write ('M = ') ; ReadLn (M) ;

    d:=M div 2;

    While d > 0 do

    Begin

    if M mod d = 0 then S:=S+d;

    d:=d-1

    End;

    if M = S then WriteLn ('Это число - совершенное')

    else WriteLn ('Данное число не является совершенным')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Натуральное число M называется совершенным, если оно равно сумме всех своих делителей, включая единицу, но исключая себя, является ли число ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На языке паскаль абс написать программу (Не глушилку, а нормальную программу) (желательно с помощью Циклов и If-ов) Натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая само число.
Ответы (1)
Напишите программу, которая вводит число N и определяет является ли число N совершенным. Совершенные числа - это те числа, которые равны сумме своих делителей, не включая само число, но включаю единицу
Ответы (1)
1) Какие операторы используются для организации циклов? a) while условие until; b) repeat until условие; c) while условие do; d) repeat do условие.
Ответы (1)
Дано натуральное число N. Определить, является ли оно совершенным (совершенное число равно сумме всех своих делителей, не превосходящих само число)
Ответы (1)
Найти все совершенные числа до 100000. Совершенное число - это такое число, которое равно сумме всех своих делителей, кроме себя самого. Например, число 6 является совершенным, т. к.
Ответы (1)