Задать вопрос
5 октября, 04:21

Напишите программу, которая вводит число N и определяет является ли число N совершенным. Совершенные числа - это те числа, которые равны сумме своих делителей, не включая само число, но включаю единицу

+1
Ответы (1)
  1. 5 октября, 07:05
    0
    Var n, i, s:integer;

    begin

    read (n) ;

    s:=0;

    for i:=1 to n-1 do begin

    if n mod i = 0 then s:=s+i;

    end;

    if s = n then writeln ('sovershennoye') else writeln ('ne sovershennoye') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая вводит число N и определяет является ли число N совершенным. Совершенные числа - это те числа, которые равны ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На языке паскаль абс написать программу (Не глушилку, а нормальную программу) (желательно с помощью Циклов и If-ов) Натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая само число.
Ответы (1)
Натуральное число M называется совершенным, если оно равно сумме всех своих делителей, включая единицу, но исключая себя, является ли число м совершенным? Напиши программу в паскале циклов while или repeat
Ответы (1)
Найти все совершенные числа до 100000. Совершенное число - это такое число, которое равно сумме всех своих делителей, кроме себя самого. Например, число 6 является совершенным, т. к.
Ответы (1)
Простые числа - это натуральные числа, которые делятся без остатка только на себя и на единицу: 2, 3, 5, 7, 11 ... 1) Разработайте программу, которая вводит число К и проверяет, является ли оно простым.
Ответы (1)
1) Запишите внутреннее представление десятичного числа - 104 в 8-разрядной ячейке памяти компьютера Ниже запишите ответ - только само число, без пояснений 2) Запишите внутреннее представление десятичного числа 79 в 8-разрядной ячейке памяти
Ответы (1)