Задать вопрос
30 июня, 09:05

Простые числа - это натуральные числа, которые делятся без остатка только на себя и на единицу: 2, 3, 5, 7, 11 ...

1) Разработайте программу, которая вводит число К и проверяет, является ли оно простым.

2) Разработайте программу, которая вводит натуральные числа А и В и выводит все заключённые между ними простые числа.

3) Разработайте программу, которая вводит с клавиатуры число К и выводит первые К простых чисел.

+1
Ответы (1)
  1. 30 июня, 11:25
    0
    1)

    var k, i, n:integer;

    begin

    write ('k = ') ; readln (k) ;

    n:=0;

    for i:=2 to round (sqrt (k)) do

    if k mod i = 0 then n:=n+1;

    if n=0 then writeln (k,' - простое число')

    else writeln (k,' - составное число') ;

    end.

    Пример:

    k = 23

    23 - простое число

    2)

    var a, b, i:integer;

    function prost (n:integer) : boolean;

    var j, m:integer;

    begin

    m:=0;

    for j:=2 to trunc (sqrt (n)) do

    if n mod j = 0 then inc (m) ;

    prost:=m=0;

    end;

    begin

    readln (a, b) ;

    writeln ('Простые числа:') ;

    for i:=a to b do

    if prost (i) then write (i,' ') ;

    end.

    Пример:

    10 30

    Простые числа:

    11 13 17 19 23 29

    3)

    var k, i, n:integer;

    function prost (n:integer) : boolean;

    var j, m:integer;

    begin

    m:=0;

    for j:=2 to trunc (sqrt (n)) do

    if n mod j = 0 then inc (m) ;

    prost:=m=0;

    end;

    begin

    readln (k) ;

    i:=2; n:=0;

    writeln ('Простые числа:') ;

    while n
    begin

    if prost (i) then begin write (i,' ') ; n:=n+1; end;

    i:=i+1;

    end;

    end.

    Пример:

    10

    Простые числа:

    2 3 5 7 11 13 17 19 23 29
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Простые числа - это натуральные числа, которые делятся без остатка только на себя и на единицу: 2, 3, 5, 7, 11 ... 1) Разработайте ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На языке программирования Pascal составить программу, которая проверяет, является ли введенное с клавиатуры число простым или нет (т. е. число делится только на 1 и на само себя без остатка) (число 354)
Ответы (1)
Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами.
Ответы (1)
Составьте задачу на Паскаль, используя диалог с пользователем. Компьютер выводит на экран: -Здравствуй, я компьютер, а тебя как зовут? Человек вводит с клавиатуры: -Коля Компьютер выводит на экран: -Очень приятно, Коля.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
составить программу которая вводит с клавиатуры длину стороны квадрата вещественного типа и выводит на экран дисплея площадь квадрата.
Ответы (1)