Задать вопрос
2 августа, 00:14

составить программу которая вводит с клавиатуры длину стороны квадрата вещественного типа и выводит на экран дисплея площадь квадрата.

процедура P1 вводит с клавиатуры длину стороны квадрата;

функция F1 вычисляет площадь квадрата;

Процедура P2 выводит на экран результат.

процедура P1 и функции F1 - встроенный в программу

процедура P2 - записывается как отдельный модуль подключаемый к основной программе.

в паскале

+5
Ответы (1)
  1. 2 августа, 02:30
    0
    программа на Turbo pascal 7.1:

    содержание progs. pas:

    {$N+}{-директива для подключения 8087 препоцессора}

    uses output1; {здесь подключаем модуль output1}

    var p:double;

    function F1 (p:double) : double;

    begin

    F1:=Sqr (p) ;

    end;

    procedure P1 (var p:double) ;

    begin

    readln (p) ;

    p:=F1 (p) ;

    end;

    begin

    write ('Введите длину стороны квадрата = ') ;

    P1 (p) ;

    P2 (p) ;

    end.

    содержание output1. tpu:

    {$N+}{-директива для подключения 8087 препоцессора}

    unit output1; {здесь объявляем модуль output1}

    interface

    procedure P2 (p:double) ;

    implementation

    procedure P2;

    begin

    writeln ('Площадь квадрата = ', p:0:5) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу которая вводит с клавиатуры длину стороны квадрата вещественного типа и выводит на экран дисплея площадь квадрата. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите по программе paskal: 1. дано целое число. напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора результат 2. дано целое число.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Составьте задачу на Паскаль, используя диалог с пользователем. Компьютер выводит на экран: -Здравствуй, я компьютер, а тебя как зовут? Человек вводит с клавиатуры: -Коля Компьютер выводит на экран: -Очень приятно, Коля.
Ответы (1)
Написать программы на языке С++ 1) С клавиатуры вводится 2 числа - целое и вещественное. Программа выводит их сумму на экран.
Ответы (1)
Составить программу - калькулятор, которая запрашивает тип математической функции: 1-квадрат, 2-куб, 3 - корень квадратный, 4 - обратная функция, а также аргумент функции x и вычисляет для x соответствующую математическую функцию.
Ответы (1)