Задать вопрос
18 октября, 16:43

На языке программирования Pascal составить программу, которая проверяет, является ли введенное с клавиатуры число простым или нет (т. е. число делится только на 1 и на само себя без остатка) (число 354)

+3
Ответы (1)
  1. 18 октября, 17:34
    0
    function isPrime (n:integer) : boolean;

    var res:boolean;

    i:integer;

    begin

    if n>1 then res:=true

    else res:=false;

    for i:=2 to n div 2 do

    if n mod i = 0 then

    begin

    res:=false;

    break;

    end;

    isPrime:=res;

    end;

    var n:integer;

    begin

    writeln ('введите целое число: n = ') ;

    readln (n) ;

    write (isPrime (n)) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На языке программирования Pascal составить программу, которая проверяет, является ли введенное с клавиатуры число простым или нет (т. е. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Запишите внутреннее представление десятичного числа - 104 в 8-разрядной ячейке памяти компьютера Ниже запишите ответ - только само число, без пояснений 2) Запишите внутреннее представление десятичного числа 79 в 8-разрядной ячейке памяти
Ответы (1)
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Простые числа - это натуральные числа, которые делятся без остатка только на себя и на единицу: 2, 3, 5, 7, 11 ... 1) Разработайте программу, которая вводит число К и проверяет, является ли оно простым.
Ответы (1)
Помогите составить программу на языке паскаль Составить программу разветвляющей структуры Написать прогрумму, которая проверяет, является ли введенное с клавиатуры число четным и положительным
Ответы (1)
1. Составьте программу, проверяющую, что введенное число является четным или нечетным 2. Составьте программу, проверяющую, что введенное число делится без остатка на 3
Ответы (1)