Задать вопрос
19 апреля, 04:47

Вывести все совершенные числа в промежутке от 1 до 100. Совершенное число это натуральное число равное сумме своих собственных делителей (отличных от самого числа)

+5
Ответы (1)
  1. 19 апреля, 06:57
    0
    Var i, j, s: integer;

    Begin

    For j:=1 to 100 do

    Begin

    s : = 0;

    For i : = 1 to (j div 2) do

    if (j mod i = 0) then s : = s + i;

    if (j = s) then writeln (s) ;

    End;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вывести все совершенные числа в промежутке от 1 до 100. Совершенное число это натуральное число равное сумме своих собственных делителей ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С клавиатуры вводится целое число K (K
Ответы (1)
Найти все совершенные числа до 100000. Совершенное число - это такое число, которое равно сумме всех своих делителей, кроме себя самого. Например, число 6 является совершенным, т. к.
Ответы (1)
Проверить являются ли два введенных числа дружественными. Дружественные числа - пара чисел, каждое из которых равно сумме собственных делителей другого (Делителем числа называется всякий его делитель, отличный от самого числа) Дружественные числа
Ответы (1)
На языке паскаль абс написать программу (Не глушилку, а нормальную программу) (желательно с помощью Циклов и If-ов) Натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая само число.
Ответы (1)
Дано натуральное число N найдите сумму всех простых делителей этого числа и проверьте, не является ли полученная сумма полиндродано натуральное число N найдите сумму всех простых делителей этого числа и проверьте, не является ли полученная сумма
Ответы (1)