Задать вопрос
21 января, 06:14

В баскетбольной команде города 12 юношей, их рост от 178 до 198 см. Выведите рост всех членов команды, поставив на первом месте рост самого высокого баскетболиста (максимальное число на 1 место)

+2
Ответы (1)
  1. 21 января, 09:28
    0
    По идее работает правильно:

    program basketbol;

    var a:array[1 ... 12] of integer;

    i, c, g:integer;

    begin

    g:=0;

    for i:=1 to 12 do

    readln (a[i]) ;

    for i:=1 to 12 do

    if a[i] > c then c:=a[i];

    writeln () ;

    for i:=1 to 12 do

    if a[i] = c then g:=g+1;

    for i:=1 to g do writeln (c) ;

    for i:=1 to 12 do begin

    if a[i] c then writeln (a[i]) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В баскетбольной команде города 12 юношей, их рост от 178 до 198 см. Выведите рост всех членов команды, поставив на первом месте рост самого ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан целочисленный массив из 30 элементов. Элементы могут принимать значения от 160 до 200 - рост учащихся выпускного класса. В баскетбольную команду берут тех, чей рост не менее 180 см.
Ответы (1)
Составьте блок-схемы и программы для решения следующих задач. Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. · Если разность первого и последнего, превышает второе, то выведите второе число.
Ответы (1)
Составьте программу нахождения наибольшего значения роста у двух членов школьной баскетбольной команды (рост спортсменов вводится с клавиатуры).
Ответы (1)
Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то выведите их произведение.
Ответы (1)
Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты. если разностьпервых двух чисел превышает четвертое, то выведите все четыре числа без изменения.
Ответы (1)