Задать вопрос
16 сентября, 02:14

3. Дана последовательность из 100 чисел a1, ..., an, где при i=1,2 ..., n значение ai = 3*i; a) Найти сумму элементов последовательности; b) Найти среднее по всем элементам последовательности.

+2
Ответы (1)
  1. 16 сентября, 04:57
    0
    Program z1; const n = 100; Var a: array [1 ... n] of integer; i, s:integer; sz:real; Begin for i:=1 to n do begin a[i]:=3*i; write (a[i],' ') ; end; s:=0; for i:=1 to n do s:=s+a[i]; sz:=s/n; writeln; writeln ('A) ', s) ; writeln ('B) ', sz) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «3. Дана последовательность из 100 чисел a1, ..., an, где при i=1,2 ..., n значение ai = 3*i; a) Найти сумму элементов последовательности; ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
1. Дан массив натуральных чисел. Найти сумму элементов кратных данному К. 2. В целочисленной последовательности есть нулевые элементы. Создать массив из номеров этих элементов. 3. дана последовательность целых чисел а1, а2, ... аn.
Ответы (1)
Это в Паскале. Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел. И вторая: Дана последовательность чисел, количество которых заранее не известно.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)