Задать вопрос
14 апреля, 06:16

Это в Паскале.

Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел.

И вторая: Дана последовательность чисел, количество которых заранее не известно. Сколько чисел было введено до первого нуля?

Буду очень благодарен, если ответите.

+2
Ответы (1)
  1. 14 апреля, 08:27
    0
    {1}

    var

    i, n, s: integer;

    begin

    i : = 0;

    writeln ('Введите последовательность чисел, оканчивающихся отрицательным числом') ;

    repeat

    readln (n) ;

    if n > 0 then begin

    s : = s + n;

    i : = i + 1;

    end;

    until n < 0;

    writeln (s / i) ;

    end.

    {2}

    var

    i, n: integer;

    begin

    i : = 0;

    writeln ('Введите последовательность чисел, оканчивающихся 0') ;

    repeat

    readln (n) ;

    if n 0 then

    i : = i + 1;

    until n = 0;

    writeln (i) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Это в Паскале. Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1. Введено число. Известно, что оно может быть равно от 10 до 999, определить сумму цифр в этом числе Задача 2. Введено три числа. Определить количество четных из них, больших пяти Задача 3.
Ответы (1)
Прошу Помогите я вам буду очень благодарен! Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.
Ответы (1)
1 задача: Массив Z (20) заполнить целыми случайными числами в диапазоне от - 20 до 20. Вычислить CP - среднее арифметическое положительных элементов и CN - среднее арифметическое отрицательных элементов массива Z.
Ответы (1)
Составьте схему алгоритма программы, которая будет осуществлять ввод чисел до тех пор, пока не будет введено число 17. Как только будет введено число 17, программа должна вывести количество введенных чисел
Ответы (1)
Помогите 2 задачки сделать на паскале 1) с клавиатуры вводится последовательность чисел до тех пор пока не будет введено число 0. требуется найти количество чисел во введенной последовательности, оканчивающихся на цифру 7. 2) Дано целое число N.
Ответы (1)