Задать вопрос
22 мая, 08:06

Прошу Помогите я вам буду очень благодарен! Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.

+1
Ответы (1)
  1. 22 мая, 10:43
    0
    Program n1;

    var a, sum, k: integer;

    begin

    write ('введите число: ') ;

    readln (a) ;

    k:=1;

    sum:=0;

    while a0 do

    begin

    if (k=1000) or (abs (a) >30000) then break;

    if (a mod 2=0) and (a>0) and (a<256) then sum:=sum+a;

    k:=k+1;

    write ('введите число: ') ;

    readln (a) ;

    end;

    writeln ('количество: ', k) ;

    writeln ('сумма: ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Прошу Помогите я вам буду очень благодарен! Напишите программу, которая в последовательности целых чисел определяет их количество и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 4. Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.
Ответы (1)
Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. Программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (признак окончания ввода,
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3. Программа получает на вход целые числа.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)