Задать вопрос
17 июня, 22:57

Задача 1. Введено число. Известно, что оно может быть равно от 10 до 999, определить сумму цифр в этом числе

Задача 2. Введено три числа. Определить количество четных из них, больших пяти

Задача 3. Введено трехзначное число, вывести это число с отсортированными по порядку цифрами

+4
Ответы (1)
  1. 18 июня, 01:19
    0
    Задача 1.

    var a, k, l, m: Integer;

    begin

    s: = 0;

    writeln ('Введите число') ;

    readln (a) ;

    if (a>=10) and (a<=999) then

    k:=a div 100;

    l: = k div 10;

    m: = a mod 10;

    s: = k+m+l;

    writeln ('Сумма цифр в числе равна ', s) ;

    end.

    Задача 2.

    var i, a, s: Integer;

    begin

    s:=0;

    for i: = 1 to 3 do

    begin

    writeln ('Введите число №', i) ;

    readln (a) ;

    if (a>5) and (a mod 5 = 0) then

    inc (s) ;

    end;

    writeln ('Количество четных чисел, которые делятся на 5 - ', s) ;

    end.

    Задача 3

    var a, b, c, d, max, med, min: Integer;

    begin

    writeln ('Введите число') ;

    readln (a) ;

    b: = a div 100;

    c: = b div 10;

    d: = a mod 10;

    if (b
    min: = b;

    if (c
    min: = c;

    if (d
    min: = d;

    if (b>c) and (b>d) then

    max: = b;

    if (c>b) and (c>d) then

    max: = c;

    if (d>c) and (d>b) then

    max: = d;

    if (b>c) and (b
    med: = b;

    if (c>b) and (c
    med: = c;

    if (d>c) and (d
    med: = d;

    writeln (min, med, max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача 1. Введено число. Известно, что оно может быть равно от 10 до 999, определить сумму цифр в этом числе Задача 2. Введено три числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)
Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3. 2. Прочитать с клавиатуры число n и вывести на экран сумму его четных цифр 3.
Ответы (1)