Задать вопрос
29 ноября, 14:00

1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3.

2. Прочитать с клавиатуры число n и вывести на экран сумму его четных цифр

3. Вывести на экран все целые числа от а до b, кратные некоторому числу с

4. вывести на экран квадраты чисел от 1 до 100.

+1
Ответы (1)
  1. 29 ноября, 16:43
    0
    1.

    Var n, S, k:integer

    Begin

    Read (n) ;

    for i:=1 to n do

    Begin

    Read (k) ;

    if k mod 3 = 0 then

    S:=S+k;

    End;

    Write (S) ;

    End.

    2. var S, k, n:integer;

    begin

    Read (n) ;

    While n>=0 do

    Begin

    k:=n mod 10;

    if k mod 2=0 then

    S:=S+k;

    n:=n div 10;

    End;

    Write (S) ;

    End.

    3. var i, a, b, c:integer;

    Begin

    read (a) ;

    read (b) ;

    read (c) ;

    Fit i:=1 to b do

    Begin

    If I mod c=0 then write (i) ;

    End;

    End.

    4. Var i:integer;

    Begin

    For i:=1 to 100 do

    Writeln (i*i) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3. 2. Прочитать с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Из ряда натуральных чисел от 1 до 2000 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Из ряда натуральных чисел от 1 до 1500 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)