Задать вопрос
25 декабря, 08:31

Дано натуральное число N (1<=N<=10000). Требуется написать программу, определяющую для N, какая цифра больше - первая или последняя.

+3
Ответы (1)
  1. 25 декабря, 11:11
    0
    Var

    s:string;

    c1, cn:char;

    n:integer;

    begin

    Write ('Введите натуральное число: ') ; Read (n) ;

    Str (n, s) ;

    c1:=s[1];

    cn:=s[Length (s) ];

    if c1>cn then Writeln ('Первая цифра больше последней')

    else

    if c1
    else Writeln ('Первая и последняя цифры одинаковы')

    end.

    Тестовые решения

    Введите натуральное число: 362336

    Первая цифра меньше последней

    Введите натуральное число: 7341423

    Первая цифра больше последней

    Введите натуральное число: 4624

    Первая и последняя цифры одинаковы
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число N (1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b? 2. Дано натуральное число. Верно ли, что сумма его цифр больше m а само число делится на n?
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
Это цикл for: 1) даны натуральные числа X и Y. вычислить X*Y, пользуясь только оперцией сложения. 2) даны натуральные числа X и Y. вычислить X^Y 3) дано натуральное число N. найти сумму S=1+1/2+1/3 + ... + 1/N. 4) дано натуральное число N и число Х.
Ответы (1)