Задать вопрос
31 августа, 22:58

Помогите решить!

1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр.

2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.

3) Дано натуральное четырехзначное число N. Определить сумму и произведение его цифр.

+5
Ответы (1)
  1. 1 сентября, 00:28
    0
    1)

    var

    a, b, c, d: integer;

    begin

    readln (a) ;

    b : = a div 100; { сотни }

    c : = (a mod 100) div 10; { десятки }

    d : = a mod 10; { единицы }

    writeln ('Сумма цифр равна: ', b + c + d) ;

    end.

    2)

    var

    a, b, c, d, p: integer;

    begin

    readln (a) ;

    b : = a div 100; { сотни }

    c : = (a mod 100) div 10; { десятки }

    d : = a mod 10; { единицы }

    p : = d * 100 + c * 10 + b;

    writeln ('Наоборот: ', p) ;

    end.

    3)

    var

    a, b, c, d, e: integer;

    begin

    readln (a) ;

    e : = a div 1000; { тысячи }

    b : = (a div 100) mod 10; { сотни }

    c : = (a mod 100) div 10; { десятки }

    d : = a mod 10; { единицы }

    writeln ('Сумма: ', e + b + c + d) ;

    writeln ('Произведение: ', e * b * c * d) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано 4-значное число. Найти: 1) число, полученное при прочтении его цифр справа налево; 2) число, образованное перестановкой двух первых и двух последних цифр заданного числа;
Ответы (1)
Запишите на языке Паскаль программу, которая для произвольного натурального двузначного числа 1) сумму и произведение его цифр; 2) число, образованное перестановкой цифр исходного числа.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
запишите на языке паскаль программу, которая для произвольного двузначного числа определяет число, образованное перестановкой цифр исходного числа.
Ответы (2)
Составьте программу, которая для произвольного натурального двузначного числа определяет число, образованное перестановкой цифр исходного числа.
Ответы (1)