Задать вопрос
8 июня, 06:51

Составьте программу, которая для произвольного натурального двузначного числа определяет число, образованное перестановкой цифр исходного числа.

+1
Ответы (1)
  1. 8 июня, 07:21
    0
    Var a, b, ab:integer;

    Begin

    write ('Введите двухзначное число - ') ; read (ab) ;

    if (ab>=10) and (ab<=99) then

    begin

    a:=ab div 10;

    b:=ab mod 10;

    writeln ('После перестановки чисел у нас получилось: ', b, a) ;

    end

    else write ('Число ', ab,' не является двухзначным ') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая для произвольного натурального двузначного числа определяет число, образованное перестановкой цифр исходного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
Запишите на языке Паскаль программу, которая для произвольного натурального двузначного числа 1) сумму и произведение его цифр; 2) число, образованное перестановкой цифр исходного числа.
Ответы (1)
запишите на языке паскаль программу, которая для произвольного двузначного числа определяет число, образованное перестановкой цифр исходного числа.
Ответы (2)
Напишите на языке Паскаль программу, которая для произвольного двухзначного числа определяет число, образованное перестановкой цифр исходного числа.
Ответы (1)
Дано 4-значное число. Найти: 1) число, полученное при прочтении его цифр справа налево; 2) число, образованное перестановкой двух первых и двух последних цифр заданного числа;
Ответы (1)