Задать вопрос
27 февраля, 07:10

1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b?

2. Дано натуральное число. Верно ли, что сумма его цифр больше m а само число делится на n?

+2
Ответы (1)
  1. 27 февраля, 07:44
    0
    Программа для 1.

    var

    n, b, s:integer;

    begin

    Write ('Введите натуральное число и значение b: ') ;

    Read (n, b) ;

    if n>b then Writeln ('Неверно')

    else begin

    s:=0;

    while n>0 do begin

    s:=s+n mod 10;

    n:=n div 10

    end;

    if s mod 2=0 then Writeln ('Верно') else Writeln ('Неверно')

    end

    end.

    Программа для 2.

    var

    k, m, n, b, s:integer;

    begin

    Write ('Введите натуральное число и значения m, n: ') ;

    Read (k, m, n) ;

    if k mod n 0 then Writeln ('Неверно')

    else begin

    s:=0;

    while k>0 do begin

    s:=s+k mod 10;

    k:=k div 10

    end;

    if s>m then Writeln ('Верно') else Writeln ('Неверно')

    end

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b? 2. Дано натуральное число. Верно ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число. Верно ли, что количество его цифр есть четное число, а само число не превышает b? Написать программу на паскале используя циклы, но не используя массивы, строковый тип и boolean
Ответы (1)
1) Запишите внутреннее представление десятичного числа - 104 в 8-разрядной ячейке памяти компьютера Ниже запишите ответ - только само число, без пояснений 2) Запишите внутреннее представление десятичного числа 79 в 8-разрядной ячейке памяти
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Даны целые числа b1, b2, ..., b10. Выяснить: а) верно ли, что сумма тех из них, которые больше 20, превышает 100; б) верно ли, что сумма тех из них, которые меньше 50, есть четное число.
Ответы (1)
Паскаль 1. Дано натуральное число. Верно ли, что в данном числе сумма цифр больше В, а само число делится на В (В вводится с клавиатуры). 2. Квадраты некоторых трехзначных чисел оканчиваются тремя цифрами, которые как раз и составляют исходные числа.
Ответы (1)