Задать вопрос
15 апреля, 14:33

Паскаль

1. Дано натуральное число. Верно ли, что в данном числе сумма цифр больше В, а само число делится на В (В вводится с клавиатуры).

2. Квадраты некоторых трехзначных чисел оканчиваются тремя цифрами, которые как раз и составляют исходные числа. Написать программу поиска таких чисел.

3. Составить программу для проверки, можно ли заданное натуральное число N представить в виде произведения двух простых чисел.

+1
Ответы (1)
  1. 15 апреля, 18:05
    0
    1)

    var

    a, b, sum : integer;

    begin

    Readln (a, b) ;

    if (a mod b = 0) then

    begin

    while a > 0 do

    begin

    sum: = sum + (a mod 10) ;

    a: = a div 10;

    end;

    if sum > b then

    begin

    Writeln ('Верно') ;

    halt;

    end;

    end;

    Writeln ('Неверно') ;

    end.

    Пример:

    1234 2

    Верно

    2)

    var

    i: integer;

    begin

    For i: = 100 to 999 do

    if (i*i) mod 1000 = i then Write (i, ' ') ;

    end.

    Результат:

    376 625

    3)

    var

    i, n : integer;

    function Simple (n: Longint) : boolean;

    var

    i: Longint;

    begin

    for i : = 2 to Round (Sqrt (n)) do

    if n mod i = 0 then

    break;

    Simple : = n mod i 0;

    end;

    begin

    Read (n) ;

    For i: = 1 to Round (Sqrt (n)) do

    if n mod i = 0 then

    if (Simple (i)) and (Simple (n div i)) then

    begin

    Writeln ('YES') ;

    halt;

    end;

    Writeln ('NO') ;

    end.

    Пример:

    33

    YES
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль 1. Дано натуральное число. Верно ли, что в данном числе сумма цифр больше В, а само число делится на В (В вводится с клавиатуры). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b? 2. Дано натуральное число. Верно ли, что сумма его цифр больше m а само число делится на n?
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
паскаль Составить программу для проверки, можно ли заданное натуральное число N представить в виде куба простого числа.
Ответы (1)
1. составить программу вывода на экран всех трехзначных чисел, кратных 9. (паскаль, тремя способами) 2. Составить программу вычисления суммы всех трехзначных чисел, кратных 17. (паскаль, тремя способами)
Ответы (1)