Задать вопрос
8 января, 19:18

1. составить программу вывода на экран всех трехзначных чисел, кратных 9. (паскаль, тремя способами) 2. Составить программу вычисления суммы всех трехзначных чисел, кратных 17. (паскаль, тремя способами)

+4
Ответы (1)
  1. 8 января, 22:07
    0
    1)

    Program Pr1;

    uses crt;

    var mas:array[100 ... 999] of integer;

    i:integer;

    Begin

    clrscr;

    for i:=100 to 999 do mas[i]:=i; {1 sposob}

    for i:=100 to 999 do if mas[i] mod 9 = 0 then writeln (mas[i]) ;

    i:=100; {2 sposob}

    while i<=999 do begin

    if mas[i] mod 9=0 then writeln (mas[i]) ;

    i:=i+1;

    end;

    i:=100; {3 sposob}

    repeat

    if mas[i] mod 9=0 then writeln (mas[i]) ;

    i:=i+1

    until i=999

    end.

    2)

    Program Pr1;

    uses crt;

    var mas:array[100 ... 999] of integer;

    i, v:integer;

    Begin

    clrscr;

    v:=0;

    for i:=100 to 999 do mas[i]:=i; {1 sposob}

    for i:=100 to 999 do if mas[i] mod 17 = 0 then v:=v+mas[i];

    writeln (v) ;

    i:=100; {2 sposob}

    v:=0;

    while i<=999 do begin

    if mas[i] mod 17=0 then v:=v+mas[i];;

    i:=i+1;

    end;

    writeln (v) ;

    i:=100; {3 sposob}

    v:=0;

    repeat

    if mas[i] mod 17=0 then v:=v+mas[i];

    i:=i+1

    until i=999;

    writeln (v) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. составить программу вывода на экран всех трехзначных чисел, кратных 9. (паскаль, тремя способами) 2. Составить программу вычисления ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Составить программу (паскаль) вывода на экран всех нечетных двухзначных чисел. 2) составить программу вычисления суммы всех трехзначных чисел, кратных 5
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Дан двухмерный массив m*n случайных целых чисел, которые должны генерироваться в диапазоне [-5, 7], где 1 ≤ т ≤ 9, 1 ≤ n ≤ 10.
Ответы (1)
Cоставить алгоритм и программу для: 1) Заполнения лвумерного массива (6x4) произвольными значениями и вывода его на экран! 2) Подсчета произведения элементов по строкам и вывода на экран номеров строк и соответствующих произведений элементов!
Ответы (1)
Создать алгоритм и написать программу вычисления площади поверхности и объёма куба ((входной параметр - длина ребра (а)) и вывода результатов на экран.
Ответы (1)