Задать вопрос
11 августа, 23:36

1. Дано натуральное число. Найти первую цифру данного числа.

2. Дано натуральное число. Определить количество троек в нем.

3. Дано натуральное число. Определить количество четных цифр в нем.

Все это при помощи цикла:while

+1
Ответы (1)
  1. 12 августа, 00:43
    0
    1. var a, b:integer;

    begin

    readln (a) ;

    while a>0 do

    begin

    b:=a mod 10;

    a:=a div 10;

    end;

    writeln ('Первая цифра: ', b) ;

    end.

    2.

    var n, count : integer;

    begin

    readln (n) ;

    while n>0 do

    begin

    if n mod 10=3 then count : = count + 1;

    n:=n div 10;

    end;

    write (count) ;

    end.

    3.

    var n, i, count : integer;

    begin

    readln (n) ;

    while n> 0 do

    begin

    i:=n mod 10;

    if odd (i) = false then count : = count + 1;

    n:=n div 10;

    end;

    writeln ('Кол-во четных цифр: ', count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сколько раз будет выполнено тело цикла? А. for i:=-5to5 do тело цикла; В. for i:=6 to 2 do тело цикла; С. for i: = 3to 3 do тло цикла; D. for i:=3 downto 4 do тело цикла E. for i : = 3 downto 1 do тело цикла
Ответы (1)
Установите взаимнооднозначное соотношение: 1) x:=1; A) Тело цикла не выполнится ни разу while x
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)