Задать вопрос
20 апреля, 23:23

Дан массив подсчитать сумму отрицательных элементов?

+5
Ответы (1)
  1. 21 апреля, 01:59
    0
    Const

    handsfree = true;

    var

    a: array[1 ... 100] of real;

    i, n: integer;

    sum: real;

    begin

    {ввод массива}

    if handsfree then

    n : = random (20) + 5

    else begin

    write ('n = ') ;

    readln (n) ;

    end;

    writeln ('Данные массива:') ;

    for i : = 1 to n do

    begin

    if handsfree then begin

    a[i] : = random (100) - 50;

    write (a[i], ' ') ;

    end

    else readln (a[i]) ;

    end;

    writeln () ;

    {подсчет суммы и произведения и агригатов}

    sum : = 0;

    for i : = 1 to n do

    if a[i] < 0 then {если нужен фильтр}

    sum : = sum + a[i];

    writeln ('sum = ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив подсчитать сумму отрицательных элементов? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)