Задать вопрос
14 января, 23:12

Помогите написать программу на Паскале

1. написать функцию, подсчитывающую количество единиц в числе и с её помощью определить, в каком из двух чисел единиц больше.

+4
Ответы (1)
  1. 15 января, 02:28
    0
    Var

    s, s2: string;

    function one (s: string) : integer;

    var i, c: integer;

    begin

    c : = 0;

    for i : = 1 to length (s) do

    if (s[i] = '1') then c : = c + 1;

    result : = c;

    end;

    begin

    writeln ('Введите первое число:') ;

    readln (s) ;

    writeln ('Введите второе число:') ;

    readln (s2) ;

    if (one (s) > one (s2)) then write ('В первом числе больше единиц')

    else write ('Во втором числе больше единиц') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу на Паскале 1. написать функцию, подсчитывающую количество единиц в числе и с её помощью определить, в каком из ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы