Задать вопрос
20 сентября, 22:06

Напишите программу, подсчитывающую количество оценок за контрольную, если в классе 20 учеников) (в Паскале)

+5
Ответы (1)
  1. 20 сентября, 22:17
    0
    const

    students = 20;

    var

    marks: byte : = students;

    begin

    writeln ('Все пришли?') ;

    var c: string;

    readln (c) ;

    if not (c in ['Yes', '1', 'True', 'Да']) then

    begin

    writeln ('Сколько не пришло?') ;

    var b: byte;

    readln (b) ;

    marks : = (marks > b? marks - b : 0) ;

    end;

    writeln (marks, ' оценок') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, подсчитывающую количество оценок за контрольную, если в классе 20 учеников) (в Паскале) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вася за 1 четверть получил по информатике 20 оценок. Чтобы вычислить какую оценку он получит необходимо найти среднее арифметическое этих оценок. Напишите программу для нахождения среднего арифметического оценок.
Ответы (1)
Написать программу в паскале Напишите программу, подсчитывающую количество различных букв в заданном слове. Входные данные: ввести строкy Y с длиной не более 255 символов.
Ответы (1)
В классе 35 учеников. Из них за контрольную по математике 12 имеют пятерки, за контрольную по физике - 9, а 16 учеников получили другие оценки. Сколько учеников получили пятерку за контрольные по обоим предметам?
Ответы (1)
В классе 20 учеников писали диктант по русскому языку. напишите программу, подсчитывающую количество двоек, троек, четверок и пятерок, полученных за диктант.
Ответы (1)
Классе 20 учеников писали диктант по русскому языку Напишите программу подсчитывающую количество двоек троек четверок и пятерок полученным за диктант
Ответы (1)