Задать вопрос
18 марта, 06:22

В классе 20 учеников писали диктант по русскому языку. напишите программу, подсчитывающую количество двоек, троек, четверок и пятерок, полученных за диктант.

+5
Ответы (1)
  1. 18 марта, 06:29
    0
    Сначала вводишь кол-во учеников: 20, затем оценки (20 оценок вводишь).

    var i, n, a, d, t, chet, p:integer;

    begin

    read (n) ;

    while i
    read (a) ;

    if a=2 then d:=d+1;

    if a=3 then t:=t+1;

    if a=4 then chet:=chet+1;

    if a=5 then p:=p+1;

    i:=i+1;

    end;

    writeln ('Двоек: ', d) ;

    writeln ('Троек: ', t) ;

    writeln ('Четверок: ', chet) ;

    writeln ('Пятерок: ', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В классе 20 учеников писали диктант по русскому языку. напишите программу, подсчитывающую количество двоек, троек, четверок и пятерок, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
в школе 20 учеников писали диктант по русскому языку. напишите программу, подсчитывающую количество двоек, троек, четверок и пятерок, полученных за диктант.
Ответы (1)
Классе 20 учеников писали диктант по русскому языку Напишите программу подсчитывающую количество двоек троек четверок и пятерок полученным за диктант
Ответы (1)
Составьте программу и блок-схему для решения следующей задачи. Учитель за урок ставит A двоек, B троек, C четверок, D пятерок (A, B, C и D каждый день разные). Сколько двоек, троек, четверок и пятерок поставит учитель за учебную неделю.
Ответы (1)
Помогите решить задачу! Вычислить выражение с использованием стандартных функций языка Pascal: В классе N учеников. После контрольной было получено: A - пятерок, B - четверок, C - троек. Найти процент троек, четверок и пятерок.
Ответы (1)
В классе N - учеников по контрольной получили A - пятерок, B - четвёрок, C - троек. Найти процент A, B, C
Ответы (1)