Задать вопрос
3 октября, 17:27

Помогите решить задачу!

Вычислить выражение с использованием стандартных функций языка Pascal:

В классе N учеников. После контрольной было получено: A - пятерок, B - четверок, C - троек. Найти процент троек, четверок и пятерок.

+3
Ответы (1)
  1. 3 октября, 19:42
    0
    Var N, A, B, C : integer;

    begin

    writeln ('Количество человек в классе:') ; readln (N) ;

    writeln ('Количество пятёрок:') ; readln (A) ;

    writeln ('Количество четвёрок:') ; readln (B) ;

    writeln ('Количество троек; ') ; readln (C) ;

    writeln ('Процент пятёрок: ', A*100 div N,'% ', 'Процент четвёрок: ', B*100 div N, '% ', 'Процент троек: ', C*100 div N, '% ') ; readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачу! Вычислить выражение с использованием стандартных функций языка Pascal: В классе N учеников. После контрольной было ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу и блок-схему для решения следующей задачи. Учитель за урок ставит A двоек, B троек, C четверок, D пятерок (A, B, C и D каждый день разные). Сколько двоек, троек, четверок и пятерок поставит учитель за учебную неделю.
Ответы (1)
В классе N - учеников по контрольной получили A - пятерок, B - четвёрок, C - троек. Найти процент A, B, C
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
В классе 30 человек. За контрольную работу по математике получено 6 пятерок, 15 четверок, 8 троек и 1 двойка. Какое количество информации в сообщении о том, что Иванов получил четверку?
Ответы (1)