Задать вопрос
18 февраля, 10:24

Классе 20 учеников писали диктант по русскому языку Напишите программу подсчитывающую количество двоек троек четверок и пятерок полученным за диктант

+5
Ответы (1)
  1. 18 февраля, 11:36
    0
    Var

    a:array [1 ... 20] of integer;

    d, t, c, p: integer;

    begin

    d:=0; t:=0; c:=0; p:=0;

    for i:=1 to 20 do begin

    writeln ('Введите оценку') ;

    read (a[i]) ;

    if a[i]=2 then d:=d+1;

    if a[i]=3 then t:=t+1;

    if a[i]=4 then c:=c+1;

    if a[i]=5 then p:=p+1;

    end;

    writeln ('Пятерок - ', ' ', p) ;

    writeln ('Четвёрок - ', ' ', c) ;

    writeln ('Троек - ', ' ', t) ;

    writeln ('Двоек - ', ' ', d) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Классе 20 учеников писали диктант по русскому языку Напишите программу подсчитывающую количество двоек троек четверок и пятерок полученным ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В классе 20 учеников писали диктант по русскому языку. напишите программу, подсчитывающую количество двоек, троек, четверок и пятерок, полученных за диктант.
Ответы (1)
в школе 20 учеников писали диктант по русскому языку. напишите программу, подсчитывающую количество двоек, троек, четверок и пятерок, полученных за диктант.
Ответы (1)
Составьте программу и блок-схему для решения следующей задачи. Учитель за урок ставит A двоек, B троек, C четверок, D пятерок (A, B, C и D каждый день разные). Сколько двоек, троек, четверок и пятерок поставит учитель за учебную неделю.
Ответы (1)
Помогите решить задачу! Вычислить выражение с использованием стандартных функций языка Pascal: В классе N учеников. После контрольной было получено: A - пятерок, B - четверок, C - троек. Найти процент троек, четверок и пятерок.
Ответы (1)
В классе N - учеников по контрольной получили A - пятерок, B - четвёрок, C - троек. Найти процент A, B, C
Ответы (1)