Задать вопрос
11 августа, 10:39

Написать программу в паскале

Напишите программу, подсчитывающую количество

различных букв в заданном слове.

Входные данные: ввести строкy Y с длиной не более 255 символов.

Выходные данные: вывести одно число, количество различных символов в

данной строке.

+1
Ответы (1)
  1. 11 августа, 14:25
    0
    var

    y, b: string;

    i: integer;

    begin

    readln (y) ;

    for i : = 1 to length (y) do

    if (Pos (y[i], b) = 0) then

    b : = concat (b, y[i]) ;

    writeln (length (b)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в паскале Напишите программу, подсчитывающую количество различных букв в заданном слове. Входные данные: ввести строкy Y ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Какие из последовательностей могут быть масками? 255.255.255.122 255.255.128.255 255.255.156.0 255.255.255.192 255.255.224.192 255.255.255.128 255.255.128.128 255.255.128.0 255.255.255.102 255.255.248.0
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)