Задать вопрос
26 октября, 11:28

Напишите программу в Паскаль: Для n произвольно введенных чисел с клавиатуры вычислить сумму и количество кратных 3 и не кратных 6 и произведение нечетных (на простом уровне)

+5
Ответы (1)
  1. 26 октября, 15:04
    0
    Program n1;

    var i, a, sum, k, p, n: integer;

    begin

    write ('введите кол-во чисел: ') ;

    readln (n) ;

    sum:=0;

    k:=0;

    p:=1;

    for i:=1 to n do

    begin

    write ('введите ', i,' число: ') ;

    readln (a) ;

    if (a mod 3=0) and (a mod 60)

    then

    begin

    sum:=sum+a;

    k:=k+1;

    end;

    if a mod 20 then p:=p*a;

    end;

    writeln ('сумма: ', sum) ;

    writeln ('количество: ', k) ;

    writeln ('произведение: ', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в Паскаль: Для n произвольно введенных чисел с клавиатуры вычислить сумму и количество кратных 3 и не кратных 6 и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
Помогите! 1) Составь программу для решения уравнения ax=b, произвольно вводимых с клавиатуры a и b. 2) Написать программу, которая вычисляет сумму нечетных чисел от 11 и до n задаваемого клавиатуры, но больше 11
Ответы (2)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Помогите написать программы ... Задача 1 Напишите программу, умеющую проверить положительное ли число, введённое с клавиатуры Задача 2 Напишите программу в которой из двух введенных с клавиатуры чисел, большее из них выведется на экран Задача 3
Ответы (1)